Sub Tank Not Working - Check Your Earth Connection

Post Reply
User avatar
JTEC
Senior Member
Senior Member
Posts: 133
Joined: 04 May 2019 14:08
Full Name: Jade Dafel
Nickname: JTEC
Home Town: Somerset West
Current 4x4: 2004 Patrol 4.8 GRX
Home Language: English
Has thanked: 123 times
Been thanked: 48 times

Sub Tank Not Working - Check Your Earth Connection

Post by JTEC »

So this weekend just after I left for a bachelors weekend with some mates I ran out of fuel due to my Sub Tank not working. I called the first person I could think of mr Tinus, he suggested to try the hard reset by removing the battery terminals for 15 minutes. It was the right thing to try but unfortunately didn't work for me. Thankfully we were close enough to Uber to the nearest fuel station to get some fuel for the main tank. We finally got going and had a jol the rest of the weekend.

Now when I got back I went through all the fuses but they were fine. I then done some research and finally found the problem to be a bad earth to the battery. After removing the terminals I cleaned up the surfaces with some sand paper and reconnected. I then done another a hard reset. :eureka: It was working again. :thumbup:

It seems that the GU is know for a bad earth connection and can be the cause to a few problems. Im going to be running another earth to the chassis for piece of mind. Hope this can help someone else :mytwocents:

User avatar
Tinus lotz
Moderator
Posts: 7992
Joined: 29 Aug 2010 13:07
Full Name: Tinus lotz
Nickname: Tinus lotz
Home Town: Centurion
Current 4x4: Nissan patrol 4.8 GRX 2005

Toyota 2.7 legend 35 LWB 4X4
Home Language: Afrikaans
Has thanked: 709 times
Been thanked: 452 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by Tinus lotz »

Lekke man glad you got the problem :bravo:

User avatar
petri oosthuizen
Senior Member
Senior Member
Posts: 285
Joined: 20 Dec 2009 19:25
Full Name: oosthuizen
Nickname: petri
Home Town: bethlehem, eastern fs
Current 4x4: 1998 Patrol 4500 GRX......."OLIVE"
1997 Cruiser HZJ 75........."JACK"
2008 Merc CL 500............."BULLET"
2006 C 180 K Manual........."SUSSIE"
En Mamma se Kar, 'n Ford
Home Language: afrikaans
Has thanked: 42 times
Been thanked: 30 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by petri oosthuizen »

JTEC...……...If I may also post a similar Problem I have in here, then no need for another Thread, really hope its OK with you??

Guys in the Know...….when travelling back from Boksburg today with my "new" GRX, I only filled the Main Tank, not the Sub.

Sub shows empty.

But that " Sub tank" button:

1) If I put the ingnition on, theres a subtank light showing

2) If I press that button, no light (after start), and the nutton also does not "stick" or "stop", it just feels loose (sorry dunno how to express myself here).

3) That sub tank light must be on, surely, when the subtank switch is activated??

THANKS

That's the ONLY issue I picked up on my way back.

And once again, the fuel consumption surprised me...…..and I was gunning it at times. So - once again, and maybe for the 10th time MY experience?? Daai manne was se die Trol is soveel swaarder as X, Y of Z weet GLAD nie waarvan hulle praat nie :blonde: :blonde:
"Fear?? Looking over at Joe Louis' corner, and knowing he wants to go home early tonight"..........Max Baer

User avatar
JTEC
Senior Member
Senior Member
Posts: 133
Joined: 04 May 2019 14:08
Full Name: Jade Dafel
Nickname: JTEC
Home Town: Somerset West
Current 4x4: 2004 Patrol 4.8 GRX
Home Language: English
Has thanked: 123 times
Been thanked: 48 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by JTEC »

petri oosthuizen wrote:
18 Feb 2020 21:08
JTEC...……...If I may also post a similar Problem I have in here, then no need for another Thread, really hope its OK with you??

Guys in the Know...….when travelling back from Boksburg today with my "new" GRX, I only filled the Main Tank, not the Sub.

Sub shows empty.

But that " Sub tank" button:

1) If I put the ingnition on, theres a subtank light showing

2) If I press that button, no light (after start), and the nutton also does not "stick" or "stop", it just feels loose (sorry dunno how to express myself here).

3) That sub tank light must be on, surely, when the subtank switch is activated??

THANKS

That's the ONLY issue I picked up on my way back.

And once again, the fuel consumption surprised me...…..and I was gunning it at times. So - once again, and maybe for the 10th time MY experience?? Daai manne was se die Trol is soveel swaarder as X, Y of Z weet GLAD nie waarvan hulle praat nie :blonde: :blonde:
No problem Petri

The subtank light on the dash display does show on mine when putting ignition on but then goes off. The button does not stick, there is no click feeling, its just a push button(spoungy) and then yes the little green light should come on when activated..BUT...there are a few things that are need for the subtank to activate. Firstly it must have fuel in it to activate, then the main tank must also be lower than a specific amount (cant remember think it was half tank). Please note im only commenting on what iv read on other forums. The pros can correct me.

User avatar
petri oosthuizen
Senior Member
Senior Member
Posts: 285
Joined: 20 Dec 2009 19:25
Full Name: oosthuizen
Nickname: petri
Home Town: bethlehem, eastern fs
Current 4x4: 1998 Patrol 4500 GRX......."OLIVE"
1997 Cruiser HZJ 75........."JACK"
2008 Merc CL 500............."BULLET"
2006 C 180 K Manual........."SUSSIE"
En Mamma se Kar, 'n Ford
Home Language: afrikaans
Has thanked: 42 times
Been thanked: 30 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by petri oosthuizen »

JTEC wrote:
19 Feb 2020 08:02
petri oosthuizen wrote:
18 Feb 2020 21:08
JTEC...……...If I may also post a similar Problem I have in here, then no need for another Thread, really hope its OK with you??

Guys in the Know...….when travelling back from Boksburg today with my "new" GRX, I only filled the Main Tank, not the Sub.

Sub shows empty.

But that " Sub tank" button:

1) If I put the ingnition on, theres a subtank light showing

2) If I press that button, no light (after start), and the nutton also does not "stick" or "stop", it just feels loose (sorry dunno how to express myself here).

3) That sub tank light must be on, surely, when the subtank switch is activated??

THANKS

That's the ONLY issue I picked up on my way back.

And once again, the fuel consumption surprised me...…..and I was gunning it at times. So - once again, and maybe for the 10th time MY experience?? Daai manne was se die Trol is soveel swaarder as X, Y of Z weet GLAD nie waarvan hulle praat nie :blonde: :blonde:
No problem Petri

The subtank light on the dash display does show on mine when putting ignition on but then goes off. The button does not stick, there is no click feeling, its just a push button(spoungy) and then yes the little green light should come on when activated..BUT...there are a few things that are need for the subtank to activate. Firstly it must have fuel in it to activate, then the main tank must also be lower than a specific amount (cant remember think it was half tank). Please note im only commenting on what iv read on other forums. The pros can correct me.
THANKS will try that! Damn - filled up the Main Tank, just last night. Makes sense that the Sub must have fuel in, oherwise the pompie(??) runs dry?
"Fear?? Looking over at Joe Louis' corner, and knowing he wants to go home early tonight"..........Max Baer

User avatar
iandvl
Patrolman 1000+
Patrolman 1000+
Posts: 1670
Joined: 12 Jan 2015 13:26
Full Name: Ian de Villiers
Nickname: Ian
Home Town: Garsfontein
Current 4x4: Nissan Patrol 4.5 GRX
Home Language: English
Has thanked: 255 times
Been thanked: 353 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by iandvl »

About the subtank:

1: The dashboard subtank light will burn when the ignition is on but the vehicle is not started. Most lights do this, as it allows the driver to ensure that all the warning lights are in fact working.
2: The light should go off when the vehicle is started. As well as all the other warning lights.
3: Believe it or not, the subtank is actually engaged for a few seconds when the vehicle is started. I believe it is about 6 seconds.
4: If the subtank is empty, there is no way to activate the pump via the switch. It simply will not switch on.
5: I don't believe tank levels play a roll in when it is possible to pump fuel across between the two. I think you can pump from subtank to main at any point - provided there is enough space in the main tank. The subtank will stop when the main tank is full. However, I stand to be corrected on this.
6: There are some cases where the subtanks do give issues. In this case, the dashboard subtank warning light will burn and it will not be possible to engage the pump via the switch on the dash. There are several threads on this, including this one.

I'm pretty sure it is working correctly, considering what you've described. Fill up the subtank and give it a run.

A final note: When I engage the subtank pump from the switch on the dash, there is a light that burns inside the switch to show that it is operating. However, in my truck, this light is not very bright. So I battle to see whether the light is burning on a bright sunny day. Just bear that in mind when you want to test. Test it in the shade, as I'm unsure how bright that light is in other trucks.

User avatar
petri oosthuizen
Senior Member
Senior Member
Posts: 285
Joined: 20 Dec 2009 19:25
Full Name: oosthuizen
Nickname: petri
Home Town: bethlehem, eastern fs
Current 4x4: 1998 Patrol 4500 GRX......."OLIVE"
1997 Cruiser HZJ 75........."JACK"
2008 Merc CL 500............."BULLET"
2006 C 180 K Manual........."SUSSIE"
En Mamma se Kar, 'n Ford
Home Language: afrikaans
Has thanked: 42 times
Been thanked: 30 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by petri oosthuizen »

Dankie Ian, sorry vir al die (onnodige) vrae, ek kon ge search het. :rolleyes:
"Fear?? Looking over at Joe Louis' corner, and knowing he wants to go home early tonight"..........Max Baer

User avatar
iandvl
Patrolman 1000+
Patrolman 1000+
Posts: 1670
Joined: 12 Jan 2015 13:26
Full Name: Ian de Villiers
Nickname: Ian
Home Town: Garsfontein
Current 4x4: Nissan Patrol 4.5 GRX
Home Language: English
Has thanked: 255 times
Been thanked: 353 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by iandvl »

petri oosthuizen wrote:
19 Feb 2020 11:39
Dankie Ian, sorry vir al die (onnodige) vrae, ek kon ge search het. :rolleyes:
G'n probleem nie Petri. Ek help met graagte. :biggrin: :biggrin:

User avatar
petri oosthuizen
Senior Member
Senior Member
Posts: 285
Joined: 20 Dec 2009 19:25
Full Name: oosthuizen
Nickname: petri
Home Town: bethlehem, eastern fs
Current 4x4: 1998 Patrol 4500 GRX......."OLIVE"
1997 Cruiser HZJ 75........."JACK"
2008 Merc CL 500............."BULLET"
2006 C 180 K Manual........."SUSSIE"
En Mamma se Kar, 'n Ford
Home Language: afrikaans
Has thanked: 42 times
Been thanked: 30 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by petri oosthuizen »

…….Nou om Olive te ry dat haar tenk so 3/4 is, nie heeltemal vol nie.

Sal probeer so 10 minuutjies afknyp om so 3 keer om die blok te ry :biggrin:

O ja, haar naam is "OLIVE"...……...en ja,as 'n Used Car Stealer 'n Kar 'n naam beginne gee moet julle weet hy like hom :lol: :blonde:
"Fear?? Looking over at Joe Louis' corner, and knowing he wants to go home early tonight"..........Max Baer

User avatar
petri oosthuizen
Senior Member
Senior Member
Posts: 285
Joined: 20 Dec 2009 19:25
Full Name: oosthuizen
Nickname: petri
Home Town: bethlehem, eastern fs
Current 4x4: 1998 Patrol 4500 GRX......."OLIVE"
1997 Cruiser HZJ 75........."JACK"
2008 Merc CL 500............."BULLET"
2006 C 180 K Manual........."SUSSIE"
En Mamma se Kar, 'n Ford
Home Language: afrikaans
Has thanked: 42 times
Been thanked: 30 times

Re: Sub Tank Not Working - Check Your Earth Connection

Post by petri oosthuizen »

Daai Subtank werk BAIE BAIE nice, thanks for all the advise!!!
"Fear?? Looking over at Joe Louis' corner, and knowing he wants to go home early tonight"..........Max Baer

Post Reply

Return to “13. Electrical & Electronics”

Who is online

Users browsing this forum: No registered users and 3 guests